<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><link data-optimized="2" rel="stylesheet" href="https://stl.news/wp-content/litespeed/cssjs/17b6d.css?bc486" /><meta http-equiv="x-dns-prefetch-control" content="on"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><title>Idaho Governor Seeks Applicants for Fish &amp; Game Commission &#8211; STL.News</title><meta name='robots' content='max-image-preview:large' /><meta property="og:title" content="Idaho Governor Seeks Applicants for Fish &amp; Game Commission" /><meta property="og:description" content="Boise, ID (STL.News) Governor Brad Little is accepting applications for the Panhandle Region representative on the Idaho Fish and Game Commission following" /><meta property="og:url" content="https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/" /><meta property="og:image" content="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg" /><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Idaho Governor Seeks Applicants for Fish &amp; Game Commission" /><meta name="twitter:description" content="Boise, ID (STL.News) Governor Brad Little is accepting applications for the Panhandle Region representative on the Idaho Fish and Game Commission following" /><meta name="twitter:image" content="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg" /><meta name="author" content="Maryam Shah" /><link rel="amphtml" href="https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/amp/" /><meta name="generator" content="AMP for WP 1.0.76.17" /><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//cdn.ampproject.org' /><link rel='dns-prefetch' href='//fonts.gstatic.com' /><link rel='dns-prefetch' href='//cdn.onesignal.com' /><link rel="alternate" type="application/rss+xml" title="STL.News &raquo; Feed" href="https://stl.news/feed/" /><link rel="alternate" type="application/rss+xml" title="STL.News &raquo; Comments Feed" href="https://stl.news/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="STL.News &raquo; Idaho Governor Seeks Applicants for Fish &amp; Game Commission Comments Feed" href="https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/feed/" /> <script src='https://stl.news/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script src='https://www.googletagmanager.com/gtag/js?id=UA-36412036-54' id='google_gtagjs-js' async></script> <script id='google_gtagjs-js-after' src="data:text/javascript;base64,d2luZG93LmRhdGFMYXllcj13aW5kb3cuZGF0YUxheWVyfHxbXTtmdW5jdGlvbiBndGFnKCl7ZGF0YUxheWVyLnB1c2goYXJndW1lbnRzKTt9Cmd0YWcoJ3NldCcsJ2xpbmtlcicseyJkb21haW5zIjpbInN0bC5uZXdzIl19KTtndGFnKCJqcyIsbmV3IERhdGUoKSk7Z3RhZygic2V0IiwiZGV2ZWxvcGVyX2lkLmRaVE5pTVQiLHRydWUpO2d0YWcoImNvbmZpZyIsIlVBLTM2NDEyMDM2LTU0Iix7ImFub255bWl6ZV9pcCI6dHJ1ZX0pOw==" defer></script> <link rel="https://api.w.org/" href="https://stl.news/wp-json/" /><link rel="alternate" type="application/json" href="https://stl.news/wp-json/wp/v2/posts/446165" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://stl.news/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://stl.news/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.2" /><link rel="canonical" href="https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/" /><link rel='shortlink' href='https://stl.news/?p=446165' /><link rel="alternate" type="application/json+oembed" href="https://stl.news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstl.news%2Fidaho-governor-seeks-applicants-for-fish-game-commission%2F446165%2F" /><link rel="alternate" type="text/xml+oembed" href="https://stl.news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstl.news%2Fidaho-governor-seeks-applicants-for-fish-game-commission%2F446165%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.32.0" />
<script type="application/ld+json" class="saswp-schema-markup-output">[{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","@id":"https:\/\/stl.news\/idaho-governor-seeks-applicants-for-fish-game-commission\/446165\/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/stl.news","name":"STL.News"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/stl.news\/idaho-governor-seeks-applicants-for-fish-game-commission\/446165\/","name":"Idaho Governor Seeks Applicants for Fish &amp; Game Commission"}}]},

{"@context":"https:\/\/schema.org","@type":"NewsArticle","@id":"https:\/\/stl.news\/idaho-governor-seeks-applicants-for-fish-game-commission\/446165\/#newsarticle","url":"https:\/\/stl.news\/idaho-governor-seeks-applicants-for-fish-game-commission\/446165\/","headline":"Idaho Governor Seeks Applicants for Fish &amp; Game Commission","mainEntityOfPage":"https:\/\/stl.news\/idaho-governor-seeks-applicants-for-fish-game-commission\/446165\/","datePublished":"2021-05-14T13:20:09-05:00","dateModified":"2021-05-14T13:20:09-05:00","description":"Boise,\u00a0ID\u00a0(STL.News) Governor\u00a0Brad Little\u00a0is accepting applications for the Panhandle Region representative on the Idaho Fish and Game Commission following the retirement of Commissioner Brad Corkill. Corkill was appointed to the Idaho Fish and Game Commission in 2013. \u201cI want to thank Brad for his dedicated service to the people and wildlife of Idaho,\u201d Governor Little said.\u00a0","articleSection":"Politics","articleBody":"Boise,\u00a0ID\u00a0(STL.News) Governor\u00a0Brad Little\u00a0is accepting applications for the Panhandle Region representative on the Idaho Fish and Game Commission following the retirement of Commissioner Brad Corkill.    Corkill was appointed to the Idaho Fish and Game Commission in 2013.    \u201cI want to thank Brad for his dedicated service to the people and wildlife of Idaho,\u201d Governor Little said.\u00a0 \u201cI have no doubt he will take his love of and commitment to sportsmanship into his retirement. I wish him well.\u201d    Corkill is a registered Republican.\u00a0 Idaho law requires no more than four commissioners on the seven-member commission to be affiliated with any one political party.    Qualified individuals interested in applying for the vacancy are encouraged to submit applications to the Governor\u2019s Office by Friday, June 4, 2021.    Applications and other appointment information are available at https:\/\/gov.idaho.gov\/appointments\/.","keywords":"brad little, Fish &amp; Game Commission, Governor, Idaho, ","name":"Idaho Governor Seeks Applicants for Fish &amp; Game Commission","thumbnailUrl":"https:\/\/stl.news\/wp-content\/uploads\/2021\/05\/Idaho-capitol-1-150x150.jpg","wordCount":"127","timeRequired":"PT33S","mainEntity":{"@type":"WebPage","@id":"https:\/\/stl.news\/idaho-governor-seeks-applicants-for-fish-game-commission\/446165\/"},"author":{"@type":"Person","name":"Maryam Shah","description":"Maryam Shah is a teacher, mother, and wife.  She is dedicated to publishing news provided by the US Department of State, State Governors, and more.  She constantly monitors the web for the latest news updates, quickly publishing stories to help keep the public informed.","url":"https:\/\/stl.news\/author\/publisher3\/","sameAs":[],"image":{"@type":"ImageObject","url":"https:\/\/stl.news\/wp-content\/uploads\/2021\/04\/82ab3533ee71daf256f23c1ccf20ad6f.jpg","height":96,"width":96}},"editor":{"@type":"Person","name":"Maryam Shah","description":"Maryam Shah is a teacher, mother, and wife.  She is dedicated to publishing news provided by the US Department of State, State Governors, and more.  She constantly monitors the web for the latest news updates, quickly publishing stories to help keep the public informed.","url":"https:\/\/stl.news\/author\/publisher3\/","sameAs":[],"image":{"@type":"ImageObject","url":"https:\/\/stl.news\/wp-content\/uploads\/2021\/04\/82ab3533ee71daf256f23c1ccf20ad6f.jpg","height":96,"width":96}},"publisher":{"@type":"Organization","name":"STL.News, LLC","url":"https:\/\/stl.news","logo":{"@type":"ImageObject","url":"https:\/\/stl.news\/wp-content\/uploads\/2020\/12\/STL.News-Logo-States-Top-Leading-News-1-1.png","width":"200","height":"45"}},"image":[{"@type":"ImageObject","@id":"https:\/\/stl.news\/idaho-governor-seeks-applicants-for-fish-game-commission\/446165\/#primaryimage","url":"https:\/\/stl.news\/wp-content\/uploads\/2021\/05\/Idaho-capitol-1-1200x720.jpg","width":"1200","height":"720"}]}]</script> <meta name="onesignal" content="wordpress-plugin" /><link rel="icon" href="https://stl.news/wp-content/uploads/2020/11/cropped-fvstl-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://stl.news/wp-content/uploads/2020/11/cropped-fvstl-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://stl.news/wp-content/uploads/2020/11/cropped-fvstl-1-180x180.png" /><meta name="msapplication-TileImage" content="https://stl.news/wp-content/uploads/2020/11/cropped-fvstl-1-270x270.png" /><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="STL.News" /><meta property="og:title" content="Idaho Governor Seeks Applicants for Fish &amp; Game Commission" /><meta property="og:url" content="https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/" /><meta property="og:type" content="article" /><meta property="og:description" content="Boise, ID (STL.News) Governor Brad Little is accepting applications for the Panhandle Region representative on the Idaho Fish and Game Commission following the retirement of Commissioner Brad Corkill.Corkill was appointed to the Idaho Fish and Game Commission in 2013.“I want to thank Brad fo" /><meta property="og:image" content="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg" /><meta property="og:image:url" content="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg" /><meta property="og:image:secure_url" content="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg" /><meta property="article:published_time" content="2021-05-14T13:20:09-05:00" /><meta property="article:modified_time" content="2021-05-14T13:20:09-05:00" /><meta property="og:updated_time" content="2021-05-14T13:20:09-05:00" /><meta property="article:section" content="Politics" /><meta property="article:publisher" content="https://www.facebook.com/STLMONews/" /><meta name="twitter:title" content="Idaho Governor Seeks Applicants for Fish &amp; Game Commission" /><meta name="twitter:url" content="https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/" /><meta name="twitter:description" content="Boise, ID (STL.News) Governor Brad Little is accepting applications for the Panhandle Region representative on the Idaho Fish and Game Commission following the retirement of Commissioner Brad Corkill.Corkill was appointed to the Idaho Fish and Game Commission in 2013.“I want to thank Brad fo" /><meta name="twitter:image" content="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@stlnewsonline" /><link rel="canonical" href="https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/" /><meta name="description" content="Boise, ID (STL.News) Governor Brad Little is accepting applications for the Panhandle Region representative on the Idaho Fish and Game Commission following the retirement of Commissioner Brad Corkill.Corkill was appointed to the Idaho Fish and Game Commission in 2013.“I want to thank Brad fo" /><meta name="google-site-verification" content="Rit8Vm19Jspo0DhuTMOxhPhxrb4m7cmgxUBQohJL6Ts" /></head><body class="post-template-default single single-post postid-446165 single-format-standard custom-background wp-custom-logo wide"><a class="skip-link screen-reader-text" href="#content">
Skip to content</a><div class="wrapper"><header class="mg-headwidget"><div class="mg-head-detail d-none d-md-block"><div class="container"><div class="row align-items-center"><div class="col-md-6 col-xs-12 col-sm-6"><ul class="info-left"><li><i class="fa fa-calendar ml-3"></i>Fri. May 14th, 2021 <span id="time" class="time"></span></li></ul></div><div class="col-md-6 col-xs-12"><ul class="mg-social info-right"><li><span class="icon-soci facebook"><a target="_blank" href="https://web.facebook.com/STLMONews/" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-facebook"></i></a></span></li><li><span class="icon-soci twitter"><a target="_blank" href="https://twitter.com/stlnewsonline" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-twitter"></i></a></span></li><li><span class="icon-soci instagram"><a target="_blank" href="https://www.instagram.com/stl.news/" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-instagram"></i></a></span></li><li><span class="icon-soci pinterest"><a target="_blank" href="https://www.pinterest.com/stlnews/" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-pinterest-p"></i></a></span></li></ul></div></div></div></div><div class="clearfix"></div><div class="mg-nav-widget-area-back" style='background-image: url("https://stl.news/wp-content/themes/newses/images/head-back.jpg" );'><div class="overlay"><div class="inner" style="background-color:#ffffff;"><div class="container"><div class="mg-nav-widget-area"><div class="row align-items-center"><div class="col-md-4 text-center-xs">
<a href="https://stl.news/" class="navbar-brand" rel="home noopener noreferrer" data-wpel-link="internal" target="_self"><picture class="custom-logo">
<source type="image/webp" srcset="https://stl.news/wp-content/uploads/2020/12/STL.News-Logo-States-Top-Leading-News-1-1.png.webp" />
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyMDAiIGhlaWdodD0iNDUiIHZpZXdCb3g9IjAgMCAyMDAgNDUiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" width="200" height="45" data-src="https://stl.news/wp-content/uploads/2020/12/STL.News-Logo-States-Top-Leading-News-1-1.png" alt="STL.News" /><noscript><img width="200" height="45" src="https://stl.news/wp-content/uploads/2020/12/STL.News-Logo-States-Top-Leading-News-1-1.png" alt="STL.News"/></noscript>
</picture>
</a></div><div class="col-md-8 text-center-xs"><div class="mg-tpt-tag-area"></div></div></div></div></div></div></div></div><div class="mg-menu-full"><nav class="navbar navbar-expand-lg navbar-wp"><div class="container"><div class="m-header align-items-center">
<a class="mobilehomebtn" href="https://stl.news" data-wpel-link="internal" target="_self" rel="noopener noreferrer"><span class="fa fa-home"></span></a><div class="dropdown show mg-search-box"><div class="dropdown-menu searchinner" aria-labelledby="dropdownMenuLink"><form role="search" method="get" id="searchform" action="https://stl.news/"><div class="input-group">
<input type="search" class="form-control" placeholder="Search" value="" name="s" />
<span class="input-group-btn btn-default">
<button type="submit" class="btn"> <i class="fa fa-search"></i> </button>
</span></div></form></div></div></div><div class="collapse navbar-collapse" id="navbar-wp"><ul id="menu-primary" class="nav navbar-nav mr-auto"><li class="active home"><a class="nav-link homebtn" title="Home" href="https://stl.news" data-wpel-link="internal" target="_self" rel="noopener noreferrer"><span class='fa fa-home'></span></a></li><li id="menu-item-419165" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-419165 dropdown"><a class="nav-link" title="Headlines" href="https://stl.news/headline-news/" data-toggle="dropdown" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Headlines </a><ul role="menu" class=" dropdown-menu"><li id="menu-item-439037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-439037"><a class="dropdown-item" title="Social Media Room" href="https://stl.news/social-media-room/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Social Media Room</a></li></ul></li><li id="menu-item-432222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-432222"><a class="nav-link" title="General" href="https://stl.news/category/general/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">General</a></li><li id="menu-item-432223" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-432223"><a class="nav-link" title="Politics" href="https://stl.news/category/politics/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Politics</a></li><li id="menu-item-432224" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-432224"><a class="nav-link" title="Business" href="https://stl.news/category/business/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Business</a></li><li id="menu-item-432228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-432228"><a class="nav-link" title="Finance" href="https://stl.news/category/finance/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Finance</a></li><li id="menu-item-432226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-432226"><a class="nav-link" title="Health" href="https://stl.news/category/health/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Health</a></li><li id="menu-item-419167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-419167 dropdown"><a class="nav-link" title="Videos" href="https://stl.news/breaking-news-videos/" data-toggle="dropdown" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Videos </a><ul role="menu" class=" dropdown-menu"><li id="menu-item-419495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419495"><a class="dropdown-item" title="Videos - State-by-State" href="https://stl.news/breaking-news-videos-2" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Videos &#8211; State-by-State</a></li></ul></li><li id="menu-item-419168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-419168 dropdown"><a class="nav-link" title="Services" href="#" data-toggle="dropdown">Services </a><ul role="menu" class=" dropdown-menu"><li id="menu-item-432596" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-432596"><a class="dropdown-item" title="Publish Guest Post" href="https://stl.news/publish-guest-post/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Publish Guest Post</a></li><li id="menu-item-434552" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-434552"><a class="dropdown-item" title="Products- Services" href="https://stl.news/business-center/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Products- Services</a></li><li id="menu-item-419304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419304"><a class="dropdown-item" title="Business Directory" href="https://stl.news/stl-news-business-directory-listings" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Business Directory</a></li></ul></li><li id="menu-item-419170" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419170"><a class="nav-link" title="About" href="https://stl.news/about-stlnews/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">About</a></li><li id="menu-item-419169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-419169 dropdown"><a class="nav-link" title="Contact" href="https://stl.news/contact/" data-toggle="dropdown" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Contact </a><ul role="menu" class=" dropdown-menu"><li id="menu-item-419263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419263"><a class="dropdown-item" title="Sitemap" href="https://stl.news/site-navigation/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Sitemap</a></li></ul></li></ul></div><div class="desk-header pl-3 ml-auto my-2 my-lg-0 position-relative align-items-center"><div class="dropdown show mg-search-box">
<a href="#" role="button" id="dropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
<i class="fa fa-search"></i>
</a><div class="dropdown-menu searchinner" aria-labelledby="dropdownMenuLink"><form role="search" method="get" id="searchform" action="https://stl.news/"><div class="input-group">
<input type="search" class="form-control" placeholder="Search" value="" name="s" />
<span class="input-group-btn btn-default">
<button type="submit" class="btn"> <i class="fa fa-search"></i> </button>
</span></div></form></div></div></div></div></nav></div></header><div class="clearfix"></div><main id="content"><div class="container"><div class="row"><div class="col-md-12"><div class="mg-header mb-30"><div class="mg-blog-category mb-1">
<a class="newses-categories category-color-1" href="https://stl.news/category/politics/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
Politics
</a></div><h1 class="title">Idaho Governor Seeks Applicants for Fish &amp; Game Commission</h1><div class="media mg-info-author-block">
<a class="mg-author-pic" href="https://stl.news/author/publisher3/" data-wpel-link="internal" target="_self" rel="noopener noreferrer"> <picture class="avatar avatar-150 wp-user-avatar wp-user-avatar-150 alignnone photo">
<source type="image/webp" srcset="https://stl.news/wp-content/uploads/2021/04/82ab3533ee71daf256f23c1ccf20ad6f-150x150.jpg.webp" />
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://stl.news/wp-content/uploads/2021/04/82ab3533ee71daf256f23c1ccf20ad6f-150x150.jpg" width="150" height="150" alt="Maryam Shah" /><noscript><img src="https://stl.news/wp-content/uploads/2021/04/82ab3533ee71daf256f23c1ccf20ad6f-150x150.jpg" width="150" height="150" alt="Maryam Shah"/></noscript>
</picture>
</a><div class="media-body"><h4 class="media-heading"><span>By</span><a href="https://stl.news/author/publisher3/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Maryam Shah</a></h4>
<span class="mg-blog-date"><i class="fa fa-clock-o"></i>
May 14, 2021</span>
<span class="newses-tags"><i class="fa fa-tag"></i>
<a href="https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/" data-wpel-link="internal" target="_self" rel="noopener noreferrer"><a href="https://stl.news/tag/brad-little/" rel="tag">brad little</a>, <a href="https://stl.news/tag/fish-game-commission/" rel="tag noopener noreferrer" data-wpel-link="internal" target="_self">Fish &amp; Game Commission</a>, <a href="https://stl.news/tag/governor/" rel="tag noopener noreferrer" data-wpel-link="internal" target="_self">Governor</a>, <a href="https://stl.news/tag/idaho/" rel="tag noopener noreferrer" data-wpel-link="internal" target="_self">Idaho</a></a>
</span></div></div></div></div><div class="col-md-9"><div class="mg-blog-post-box">
<picture class="img-responsive wp-post-image" loading="lazy">
<source type="image/webp" srcset="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg.webp 900w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-300x168.jpg.webp 300w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-768x431.jpg.webp 768w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-560x314.jpg.webp 560w" sizes="(max-width: 900px) 100vw, 900px" />
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI5MDAiIGhlaWdodD0iNTA1IiB2aWV3Qm94PSIwIDAgOTAwIDUwNSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="900" height="505" data-src="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg" alt="Idaho Governor Seeks Applicants for Fish &amp; Game Commission" loading="lazy" data-srcset="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg 900w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-300x168.jpg 300w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-768x431.jpg 768w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-560x314.jpg 560w" data-sizes="(max-width: 900px) 100vw, 900px" /><noscript><img width="900" height="505" src="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg" alt="Idaho Governor Seeks Applicants for Fish &amp; Game Commission" loading="lazy" srcset="https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1.jpg 900w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-300x168.jpg 300w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-768x431.jpg 768w, https://stl.news/wp-content/uploads/2021/05/Idaho-capitol-1-560x314.jpg 560w" sizes="(max-width: 900px) 100vw, 900px"/></noscript>
</picture><article class="small single p-3"><p>Boise, <a href="https://stl.news/idaho/" target="_self" rel="noopener noreferrer" data-wpel-link="internal">ID</a> (<a href="https://stl.news/site-navigation/" target="_self" rel="noopener noreferrer" data-wpel-link="internal">STL.News</a>) Governor <a href="https://en.wikipedia.org/wiki/Brad_Little" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">Brad Little</a> is accepting applications for the Panhandle Region representative on the Idaho Fish and Game Commission following the retirement of Commissioner Brad Corkill.</p><p>Corkill was appointed to the Idaho Fish and Game Commission in 2013.</p><p>“I want to thank Brad for his dedicated service to the people and wildlife of Idaho,” Governor Little said.  “I have no doubt he will take his love of and commitment to sportsmanship into his retirement. I wish him well.”</p><p>Corkill is a registered Republican.  Idaho law requires no more than four commissioners on the seven-member commission to be affiliated with any one political party.</p><p>Qualified individuals interested in applying for the vacancy are encouraged to submit applications to the Governor’s Office by Friday, June 4, 2021.</p><p>Applications and other appointment information are available at https://gov.idaho.gov/appointments/.</p><div class="post-share"><div class="post-share-icons cf">
<a href="https://www.facebook.com/sharer.php?u=https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/" class="link facebook" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
<i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/share?url=https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/&#038;text=Idaho%20Governor%20Seeks%20Applicants%20for%20Fish%20%26%20Game%20Commission" class="link twitter" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
<i class="fa fa-twitter"></i></a>
<a href="/cdn-cgi/l/email-protection#8cb3fff9eee6e9eff8b1c5e8ede4e3a9bebccbe3fae9fee2e3fea9bebcdfe9e9e7ffa9bebccdfcfce0e5efede2f8ffa9bebceae3fea9bebccae5ffe4a9bebca9bebaede1fcb7a9bebccbede1e9a9bebccfe3e1e1e5ffffe5e3e2aaafbcbfb4b7eee3e8f5b1e4f8f8fcffb6a3a3fff8e0a2e2e9fbffa3e5e8ede4e3a1ebe3fae9fee2e3fea1ffe9e9e7ffa1edfcfce0e5efede2f8ffa1eae3fea1eae5ffe4a1ebede1e9a1efe3e1e1e5ffffe5e3e2a3b8b8babdbab9a3" class="link email" target="_blank">
<i class="fa fa-envelope-o"></i></a><a href="https://www.linkedin.com/sharing/share-offsite/?url=https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/&#038;title=Idaho%20Governor%20Seeks%20Applicants%20for%20Fish%20%26%20Game%20Commission" class="link linkedin" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
<i class="fa fa-linkedin"></i></a><a href="https://telegram.me/share/url?url=https://stl.news/idaho-governor-seeks-applicants-for-fish-game-commission/446165/&#038;text&#038;title=Idaho%20Governor%20Seeks%20Applicants%20for%20Fish%20%26%20Game%20Commission" class="link telegram" target="_blank" data-wpel-link="external" rel="external noopener noreferrer">
<i class="fa fa-telegram"></i></a><a href="javascript:pinIt();" class="link pinterest" data-wpel-link="internal" target="_self" rel="noopener noreferrer"><i class="fa fa-pinterest"></i></a></div></div><div class="clearfix mb-3"></div><nav class="navigation post-navigation" role="navigation" aria-label="Posts"><h2 class="screen-reader-text">Post navigation</h2><div class="nav-links"><div class="nav-previous"><a href="https://stl.news/florida-bill-allowing-to-go-sales-of-alcoholic-beverages-by-restaurants/446139/" rel="prev noopener noreferrer" data-wpel-link="internal" target="_self">Florida: Bill Allowing To-Go Sales of Alcoholic Beverages by Restaurants<div class="fa fa-angle-double-right"></div><span></span></a></div></div></nav></article></div><div class="clearfix mb-4"></div><div class="media mg-info-author-block">
<a class="mg-author-pic" href="https://stl.news/author/publisher3/" data-wpel-link="internal" target="_self" rel="noopener noreferrer"><picture class="avatar avatar-150 wp-user-avatar wp-user-avatar-150 alignnone photo">
<source type="image/webp" srcset="https://stl.news/wp-content/uploads/2021/04/82ab3533ee71daf256f23c1ccf20ad6f-150x150.jpg.webp" />
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://stl.news/wp-content/uploads/2021/04/82ab3533ee71daf256f23c1ccf20ad6f-150x150.jpg" width="150" height="150" alt="Maryam Shah" /><noscript><img src="https://stl.news/wp-content/uploads/2021/04/82ab3533ee71daf256f23c1ccf20ad6f-150x150.jpg" width="150" height="150" alt="Maryam Shah"/></noscript>
</picture>
</a><div class="media-body"><h4 class="media-heading"><a href="https://stl.news/author/publisher3/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Maryam Shah</a></h4><p>Maryam Shah is a teacher, mother, and wife. She is dedicated to publishing news provided by the US Department of State, State Governors, and more. She constantly monitors the web for the latest news updates, quickly publishing stories to help keep the public informed.</p></div></div><div class="wd-back"><div class="mg-sec-title st3"><h4><span class="bg">Related Post</span></h4></div><div class="small-list-post row"><div class="small-post media col-md-6 col-sm-6 col-xs-12"><div class="img-small-post back-img" style="background-image: url('https://stl.news/wp-content/uploads/2021/05/Florida-tala-1.jpg');">
<a href="https://stl.news/florida-bill-allowing-to-go-sales-of-alcoholic-beverages-by-restaurants/446139/" class="link-div" data-wpel-link="internal" target="_self" rel="noopener noreferrer"></a></div><div class="small-post-content media-body"><div class="mg-blog-category"> <a class="newses-categories category-color-1" href="https://stl.news/category/politics/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
Politics
</a></div><h5 class="title"><a href="https://stl.news/florida-bill-allowing-to-go-sales-of-alcoholic-beverages-by-restaurants/446139/" title="Permalink to: Florida: Bill Allowing To-Go Sales of Alcoholic Beverages by Restaurants" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
Florida: Bill Allowing To-Go Sales of Alcoholic Beverages by Restaurants</a></h5><div class="mg-blog-meta">
<a href="https://stl.news/date/2021/05/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
May 14, 2021</a></span>
<a href="https://stl.news/author/publisher3/" data-wpel-link="internal" target="_self" rel="noopener noreferrer"> <i class="fa fa-user-circle-o"></i> Maryam Shah</a></div></div></div><div class="small-post media col-md-6 col-sm-6 col-xs-12"><div class="img-small-post back-img" style="background-image: url('https://stl.news/wp-content/uploads/2021/05/Colorado-Capitol-4.jpg');">
<a href="https://stl.news/colorado-governor-makes-county-district-court-appointments/446138/" class="link-div" data-wpel-link="internal" target="_self" rel="noopener noreferrer"></a></div><div class="small-post-content media-body"><div class="mg-blog-category"> <a class="newses-categories category-color-1" href="https://stl.news/category/politics/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
Politics
</a></div><h5 class="title"><a href="https://stl.news/colorado-governor-makes-county-district-court-appointments/446138/" title="Permalink to: Colorado Governor Makes County &amp; District Court Appointments" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
Colorado Governor Makes County &amp; District Court Appointments</a></h5><div class="mg-blog-meta">
<a href="https://stl.news/date/2021/05/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
May 14, 2021</a></span>
<a href="https://stl.news/author/publisher3/" data-wpel-link="internal" target="_self" rel="noopener noreferrer"> <i class="fa fa-user-circle-o"></i> Maryam Shah</a></div></div></div><div class="small-post media col-md-6 col-sm-6 col-xs-12"><div class="img-small-post back-img" style="background-image: url('https://stl.news/wp-content/uploads/2021/05/bigstock-Nurses-Week-Vector-Horizontal-414295679.jpg');">
<a href="https://stl.news/arkansas-governor-hutchinson-nurses-make-a-difference/446137/" class="link-div" data-wpel-link="internal" target="_self" rel="noopener noreferrer"></a></div><div class="small-post-content media-body"><div class="mg-blog-category"> <a class="newses-categories category-color-1" href="https://stl.news/category/politics/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
Politics
</a></div><h5 class="title"><a href="https://stl.news/arkansas-governor-hutchinson-nurses-make-a-difference/446137/" title="Permalink to: Arkansas Governor Hutchinson: Nurses Make A Difference" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
Arkansas Governor Hutchinson: Nurses Make A Difference</a></h5><div class="mg-blog-meta">
<a href="https://stl.news/date/2021/05/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">
May 14, 2021</a></span>
<a href="https://stl.news/author/publisher3/" data-wpel-link="internal" target="_self" rel="noopener noreferrer"> <i class="fa fa-user-circle-o"></i> Maryam Shah</a></div></div></div></div></div></div><aside class="col-md-3"><div id="sidebar-right" class="mg-sidebar"><div id="nav_menu-3" class="mg-widget widget_nav_menu"><div class="mg-wid-title"><h6><span class="bg">About</span></h6></div><div class="menu-about-stl-news-container"><ul id="menu-about-stl-news" class="menu"><li id="menu-item-420528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420528"><a href="https://stl.news/business-center/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Business Center</a></li><li id="menu-item-419161" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419161"><a href="https://stl.news/submit-guest-post/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Benefits of Guest Post – Submit Guest Post</a></li><li id="menu-item-419162" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419162"><a href="https://stl.news/stl-news-media-kit/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Media Kit</a></li><li id="menu-item-419163" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419163"><a href="https://stl.news/press-release-center/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Press Release Center</a></li><li id="menu-item-419164" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419164"><a href="https://stl.news/legal-marketing/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Legal &#038; Marketing</a></li><li id="menu-item-425842" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425842"><a href="https://stl.news/press-release-writing-service/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Writing Service</a></li></ul></div></div><div id="text-8" class="mg-widget widget_text"><div class="mg-wid-title"><h6><span class="bg">Social Media &#038; Syndication</span></h6></div><div class="textwidget"><ol><li><a href="https://www.facebook.com/STLMONews" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">Facebook</a></li><li><a href="https://twitter.com/stlnewsonline" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">Twitter</a></li><li><a href="https://www.pinterest.com/stlnews/_created/" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">Pinterest</a></li><li><a href="https://stlnews.business.site/" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">Google Business Site</a></li><li><a href="https://www.newsbreak.com/channels/stl-news-500201" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">News Break App</a></li><li><a href="https://news360.com/source/806960018" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">News360</a></li><li><a href="https://www.feedpublish.com/news/" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">FeedPublish</a></li><li><a href="https://www.blogarama.com/blogging-blogs/1279312-stl-news-blog/" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">Blogarama</a></li></ol></div></div><div id="nav_menu-2" class="mg-widget widget_nav_menu"><div class="mg-wid-title"><h6><span class="bg">Links</span></h6></div><div class="menu-useful-links-container"><ul id="menu-useful-links" class="menu"><li id="menu-item-419159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419159"><a href="https://stl.news/news-reporting-first-responders/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">News Reporting for First Responders</a></li><li id="menu-item-419160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419160"><a href="https://stl.news/press-release-writing-service/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Press Release Writing Service</a></li><li id="menu-item-419249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419249"><a href="https://stlnews.business.site/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Google Business Site</a></li><li id="menu-item-425840" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-425840"><a href="https://statesnewsupdates.blogspot.com/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Google Blogger</a></li><li id="menu-item-430926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-430926"><a href="https://www.newsbreak.com/publishers/@500201" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">News Break Site/App</a></li><li id="menu-item-432046" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-432046"><a href="https://www.blogarama.com/blogs/1279312" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Blogarama</a></li></ul></div></div><div id="text-7" class="mg-widget widget_text"><div class="mg-wid-title"><h6><span class="bg">Link Building Strategies</span></h6></div><div class="textwidget"><p><a href="https://www.feedpublish.com" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">FeedPublish.com</a> is an affiliated site with a high MOZ Domain Authority (76) that offers options for <a href="https://www.feedpublish.com/subscription/" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">link building strategies</a>:</p><ol><li>Guest Posts &#8211; $20 per post</li><li>10 Guest Posts &#8211; $150</li><li>Unlimited &#8211; $300 per month</li><li>RSS Aggregation &#8211; $20 per month</li><li>Business Directory &#8211; $60 per year</li></ol></div></div><div id="text-5" class="mg-widget widget_text"><div class="mg-wid-title"><h6><span class="bg">Contact</span></h6></div><div class="textwidget"><p><a href="https://stlnews.us/" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">STL.News, LLC</a></p><p>17005 Machester Road<br />
Wildwood, Missouri 63040</p><p>Email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="165b7764626f5645425a5b73727f773857717378756f">[email&#160;protected]</a><br />
Phone: +1 417-529-1133</p><p>Email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="8cc7cde1ede2f8bdb4bbccebe1ede5e0a2efe3e1">[email&#160;protected]</a><br />
Phone: +1 314-803-8727</p></div></div></div></aside></div></div></main><footer><div><div class="mg-footer-bottom-area"><div class="container"><div class="divide-line"></div><div class="row align-items-center"><div class="col-md-6">
<a href="https://stl.news/" class="navbar-brand" rel="home noopener noreferrer" data-wpel-link="internal" target="_self"><picture class="custom-logo">
<source type="image/webp" srcset="https://stl.news/wp-content/uploads/2020/12/STL.News-Logo-States-Top-Leading-News-1-1.png.webp" />
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyMDAiIGhlaWdodD0iNDUiIHZpZXdCb3g9IjAgMCAyMDAgNDUiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNjZmQ0ZGIiLz48L3N2Zz4=" width="200" height="45" data-src="https://stl.news/wp-content/uploads/2020/12/STL.News-Logo-States-Top-Leading-News-1-1.png" alt="STL.News" /><noscript><img width="200" height="45" src="https://stl.news/wp-content/uploads/2020/12/STL.News-Logo-States-Top-Leading-News-1-1.png" alt="STL.News"/></noscript>
</picture>
</a></div><div class="col-md-6 text-right text-xs"><ul class="mg-social"><li><span class="icon-soci facebook"><a target="_blank" href="https://www.facebook.com/STLMONews" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-facebook"></i></a></span></li><li><span class="icon-soci twitter"><a target="_blank" href="https://twitter.com/stlnewsonline" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-twitter"></i></a></span></li><li><span class="icon-soci pinterest"><a target="_blank" href="https://www.pinterest.com/stlnews/" data-wpel-link="external" rel="external noopener noreferrer"><i class="fa fa-pinterest-p"></i></a></span></li></ul></div></div></div></div><div class="mg-footer-copyright"><div class="container"><div class="row"><div class="col-md-6 text-xs"></div><div class="col-md-6 text-right text-xs"><ul id="menu-footer-menu" class="info-right"><li id="menu-item-444725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-444725"><a class="nav-link" title="Press Release Writing Service" href="https://stl.news/press-release-writing-service/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Press Release Writing Service</a></li><li id="menu-item-444724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-444724"><a class="nav-link" title="Submit a Guest Post" href="https://stl.news/submit-guest-post/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Submit a Guest Post</a></li><li id="menu-item-444722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-444722"><a class="nav-link" title="About Us" href="https://stl.news/about-stlnews/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">About Us</a></li><li id="menu-item-444723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-444723"><a class="nav-link" title="Contact Us" href="https://stl.news/contact/" data-wpel-link="internal" target="_self" rel="noopener noreferrer">Contact Us</a></li></ul></div></div></div></div></div></footer></div>
<a href="#" class="ta_upscr bounceInup animated"><i class="fa fa-angle-up"></i></a>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-no-optimize="1">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</script><script data-optimized="1" src="https://stl.news/wp-content/litespeed/cssjs/02943.js?d5662" defer></script></body></html>

